This project has moved and is read-only. For the latest updates, please go here.

alternate location

Nov 16, 2011 at 7:26 PM
Edited Nov 16, 2011 at 7:29 PM

all my movies/tv shows go to the shared folder c:\users\public\Recorded TV

I have tried to insert this into the xml file so that I can then move the script to a seperate folder within this director I called "renamer"

so I edited the xml like this <recordings>c:\users\public\recorded tv\</recordings> and it didn't work so I also did it like this <recordings>"c:\users\public\recorded tv\"</recordings

so the script would be located at c:\users\public\recorded tv\renamer

 but the movies and output would be at c:\users\public\recorded tv\

i have seemingly tried all combinations of what to put where but I cannot get it to work.

i"m sure it is something simple but I cannot figure it out

 

Thanks

 

Shawn

Nov 17, 2011 at 8:41 AM

Hi Shawn

You are definitely on the right lines, and what you are trying to achieve is possible.

When you edited the XML file the first time, you say it didn't work ... what happened? Can you either include the error text or perhaps run the script with -interactive and copy/paste the full verbose output up to the error?

Thanks.

Philip

 

Nov 17, 2011 at 11:14 AM

added <recordings>'c:\users\public\recorded tv\'</recordings>

but didn't move anything yet just testing script. so everything still in this same folder.

 

got no response from -verbose or interactive I had to do a screen capture to get details of red text. don't see a way to post that

Nov 17, 2011 at 1:16 PM

Ah ... can you try taking the single quotes out and see if that fixes it?

Thanks.

Philip

 

Nov 18, 2011 at 12:00 AM

tried that with no luck

copied the xml back from the zip and tried again and it worked. so I guess the code got messed up at some point.

so I moved the xml file the ps1 file and the dll to a separate folder.it is now working.

is it supposed to put the log and the rename.ps1 in the same directory as the renamed files? that is what it is doing.

Nov 18, 2011 at 12:06 AM

for now I just turned off logs and undo script

Nov 18, 2011 at 6:38 PM

Hi Shawn

Glad that re-copying the XML file got the script working for you.

Yes, the current version of the script does put the log and the rename file in the same directory as the recordings. There is a proposal in the Issue Tracker to add functionality to allow those files to be put somewhere else.

Philip